How to add NS as an approved sender in Outlook?

Ron_O

Cave Dweller
#1
I have no idea what's going on, but for months my notifications have been going both into my inbox or my spam file. Sometimes they come into the inbox, I get a notification, but they're immediately routed to the spam file.

LOL never mind, I just figured it out.

Click on the gear icon, click on options, scroll down on the left side to 'safe senders', and add admin@nevadashooters.com .

Now let's see if it works!

UPDATE: Problem solved, going to and staying in my inbox now.
 
Last edited: